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This user guide will cover the setup and connection of Siretta’s SL500 modem to 
the SirettaLINK Management Portal. 

No prior knowledge of the operating principles of the cellular mobile network or AT 
command-based modems is needed. 

This guide will explain how to create and use a serial data connection over a 
cellular network in a simple, quick, and easy manner. 

For further technical information on the SL500 modem and the SirettaLINK 
Management Portal, you will need to subscribe to the portal at: 
https://www.siretta-link.com/management-portal/ 

You will then be able to gain access to the User Manuals for the SL500 Modems, 
and the SirettaLINK Management Portal.

Introduction
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Siretta, located in Reading, United Kingdom have been manufacturing antennas, 
cable assemblies and cellular modems for over 10 years. We supply our products 
globally to many of the world’s leading organisations.

Whether you require an off the shelf or custom solution, Siretta has a wide portfolio of 
antenna, RF cable assemblies and modems to fit your application.

Our extensive knowledge and experience in the wireless market allows us to support 
a wide range of customer applications, focusing on frequencies typically within the 
75MHz - 5.8GHz range. These encompass the HF, VHF, ISM, GSM/GPRS/3G/4G 
and GPS frequencies as well as industrial WLAN and VHF/UHF antenna/Wi-Fi 
antenna solutions.

With a heavy emphasis on design, we have a team of dedicated Application 
Engineers and Product Managers, backed up by Field Sales Engineers, who 
specialise in wireless applications.

We have made significant investments in R&D facilities which boast GPS hardware 
development equipment and a GSM Pico Cell on site, as well as development 
software and a comprehensive suite of Industrial, Scientific and Medical band, and 
non ISM band frequency products. We have many technology partners enabling us to 
keep at the forefront of the communications industry and offer class leading wireless 
solutions.

About Siretta
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This section explains the basics of setting up the SirettaLINK Management Portal 
alongside an SL500 modem.

Using SirettaLINK Management Portal

Setup and management of the SL500 modem is done via the SirettaLINK 
Management Portal: https://www.siretta-link.com/

Once you have navigated to the SirettaLINK website, select ‘Management Portal’ as 
highlighted in the figure below.

Account Login and Registration

Figure 1. Management Portal

Opens SirettaLINK
Management Portal

In order to be able to use the SL500 modem, you will need a data enabled SIM 
card. Siretta recommend using a contract SIM as these are typically activated when 
provided so there is no user interaction required to prepare them for use. 

Pay As You Go (PAYG) SIMs are usually more complicated as they require activation 
before use, this can be done using a mobile phone, and then transferred to the 
SL500 modem when activated. 

Generally, it is not advised that an SL500 modem in the field should run out of credit 
as you are required to restart your device once credit has been added. For that 
reason, a contract SIM is highly recommended or as a minimum a PAYG SIM with 
automatic top-up enabled.

SIM Selection

http://www.siretta-link.com
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If you already have an account, enter your username and password to login to the 
SirettaLINK Management Portal. 

Select ‘Login’.

If you do not have an account, see ‘Account Registration’ section over page.

Figure 2. Account Login

Account Login

Select ‘Login’ once you have 
entered your account details

If you have forgotten your password, select ‘Recover 
Password’ and follow the steps for password recovery

Select ‘Register’ if you do
not have an account

http://www.siretta-link.com
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You must complete all fields to register an account. 

Please take care to enter a valid email address as this is needed for the SirettaLINK 
Management Portal to send you system messages (such as password recovery). 

Chosen password must be at least 8 characters, contain upper and lowercase 
characters and numbers. Symbols such as # may also be used.

As fields are completed correctly, they will turn green. Once all fields have been 
completed, select ‘Register’.

Figure 3. Account registration

Account Registration

Select ‘Register’ when all fields have been completed
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Portal Overview
Once you are logged into the SirettaLINK Management Portal, you will be directed to 
the home page.

Navigation tabs are presented along the top of the screen which are used to navigate 
the portal. The default landing tab after account creation is the ‘Help’ tab. The 
active tab is always highlighted in green, inactive tabs have light grey backgrounds, 
unavailable tabs have a dark grey background. 

On account creation, the ‘Device’ and ‘Position’ tabs will be unavailable. When one 
or more SL500 modems have been added to the account these tabs will become 
accessible.

The registered account being used is shown to the left of the portal navigation 
buttons.

Figure 4. SirettaLINK homepage

Active tab is 
highlighted green

Inactive tabs are
highlighted light grey

Unavailable tabs are
highlighted dark grey

Account user details

http://www.siretta-link.com
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This section explains how to configure the SL500 modem to be used with the 
SirettaLINK Management Portal. 

Modem Configuration

Obtaining the Configuration Tool
Once logged into the SirettaLINK Management Portal, navigate to ‘Help > Adding 
New Devices’. From here you can download the configuration tool required to link 
your SL500 modem to the SirettaLINK Management Portal.

To download the configuration tool, click the ‘Download Configuration Tool’ button, 
the file is named ‘SirettaLINK_Config_Tool.exe’. This application is designed for use 
on a PC running Windows. 

NOTE: You will need the Account Key and Account ID as shown below when configuring 
communication between your SL500 modem and SirettaLINK Management Portal.

Figure 5. Download configuration tool

Click to begin download 
of configuration tool

Account Code

Account ID

http://www.siretta-link.com
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Once downloaded, double click the file to run the application. Depending on the 
version of Windows and your computers security settings (Windows Defender and 
Anti-virus) you may get a warning about it being a potentially harmful application. In 
this case, follow dialogues presented to enable the application to run.

When the configuration tool is successfully executed, the window below will be 
displayed.

Figure 6. SirettaLINK configuration tool

http://www.siretta-link.com
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Connecting SL500 Modem
For this section, you will need a data enabled SIM card and the components 
found in the SL500 modem starter kit. 

Step 1. Insert SIM card into the SL500 modem. This should be pushed all the way 
in until a small click is heard. Siretta recommend using the corner of a credit card to 
push the SIM card into the modem as this is unlikely to cause damage to the SIM.

Step 2. Connect a suitable antenna to the SL500 modem. The antenna supplied with 
the starter kit is a general purpose antenna that will be suitable for many applications.

Step 3. Connect the PC to the RS232 port of the SL500 modem. Most modern PCs 
no longer have a serial port so you will have to use the USB to serial adapter cable 
included with the starter kit to connect the PC to the serial port. Remember to install
any drivers for the USB to serial cable that may be necessary before plugging in the
adapter. The Siretta RS232 Serial Port cable should automatically install on your 
system. However if it does not install automatically then you can find installation 
instructions and drivers for the Siretta RS232 Serial Port Cable in the following link:
https://www.siretta.com/serialdrivers

Step 4. Locate the configuration function boot switch on the underside of the SL500 
modem and push the ‘Siretta Function Pin Tool’ provided with your SL500 Starter Kit 
through the hole until you hear an audible click and then apply power to the SL500 
modem.

Keep the button pressed for at least 2 seconds after power is applied until the green 
and blue LEDs illuminate and start rapidly blinking alternately. 

Figure 7. Configuration function boot switch

SL500 modem configuration function boot switch

http://www.siretta-link.com
https://www.siretta-link.com/?smd_process_download=1&download_id=6593
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The SL500 modem is successfully in configuration mode once the green and 
blue LED’s alternately flash. With the LEDs in this state, press ‘Connect’ on the 
configuration tool application. A ‘Connecting’ message will now be displayed. When 
the SL500 modem successfully connects in configuration mode, the configuration 
tool below will open.

Figure 8. Modem connected to configuration tool

Once connected, the ‘Connect’ button is renamed ‘Disconnect’, and reports the 
COM port the SL500 modem has detected. Make a note of the COM port used – this 
will be needed later to enable communication with the SL500 modem.

The ‘Account Code’ field is used to match the SL500 modem to the SirettaLINK 
Management Portal account being used. On the ‘Help > Adding New Devices’ page 
of the portal, there will be an “activation code” displayed in a green box under the 
button for downloading the configuration tool, as shown on page 9. Copy and paste 
this activation code into the ‘Account Code’ field, then click ‘Save to device’.

The ‘Network Settings’ field is required to get the SL500 modem online and enable 
connection to the SirettaLINK Management Portal. The APN, APN User and APN PW 
are settings that your chosen SIM card provider will supply and must be entered here. 
Not all network operators require an APN username or password, but a valid APN is a 
requirement for the modem to connect to the cellular network. If the SIM is protected 
by a PIN number, it must be entered, otherwise leave the SIM PIN field blank. If 
settings are blank, the SL500 modem will attempt to use the internally saved public 
APN settings. This may or may not work depending on the SIM in use.

http://www.siretta-link.com
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Once the SirettaLINK modem has been configured, click the ‘Disconnect’ button 
on the configuration tool and then power cycle the SL500 modem to take it out of 
configuration mode.

Once power has been cycled, observe the three LEDs on the side of the SL500 
modem to confirm that it is connecting to the SirettaLINK Management Portal. The 
LED functions are as follows:

Table 1. LED functions

LED Function

Red Cellular network connection status

Green SirettaLINK Management Portal connection status

Blue Client application server connection status

A connected and synchronized SL500 modem will have the green and blue LEDs 
on continuously, and the red LED flashing at 1Hz. It could take several minutes from 
power up to reach this state depending on network conditions and signal strength. 
See ‘Help > LED Status Codes’ on the SirettaLINK Management Portal for further 
detail.

When the SirettaLINK modem connects to the SirettaLINK Management Portal you 
will see that the web page changes to the ‘History’ tab, and that the newly added 
SL500 modem appears in the ‘Device’ section.

Figure 9. Audit history

http://www.siretta-link.com
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Confirming Connection
To test that the connection that has been automatically established using the factory 
default settings, Siretta recommends the use of Tera Term as a terminal emulator for 
PC. This is a free, open-source program that can be downloaded from:  
https://ttssh2.osdn.jp/index.html.en.

Click the ‘Serial’ button and select the COM port that was identified by the 
configuration tool instructions on page 12. Then click ‘OK’. 

Figure 10. Confirm connection 

Select ‘Serial COM Port’ dropdown

Click ‘OK’ when correct COM port  
has been selected

http://www.siretta-link.com
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The terminal window will appear. Tera Term defaults to a 9600 baud connection, but 
the default ‘new connection profile’ for the SL500 modems have a baud rate set to 
115200, however, you need to select whatever baud rate is configured on your unit’s 
profile. Click ‘Setup > Serial Port’ and set the port speed to 115200. Once changed, 
click ‘New Setting’ to confirm changes.

Figure 11. Set baud rate

Set baud rate 

Confirm new settings
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In the above figure, the server is sending a message string to the SL500 modem 
every 15 seconds.

Cycle power to the SL500 modem (while keeping Tera Term open, connected to the 
COM port) and see how the server recognises the reconnection and responds with 
the welcome message initially.

You can also use Tera Term to connect your PC directly to the SirettaLINK test server 
if you want to check that the connection path provided by your PC’s Internet is 
equivalent to that of the SL500 modem. In the Tera Term window, go to ‘File > New 
Connection’. In the new connection box, use the following settings:

	» TCP/IP connection: device.siretta-link.com

	» Port: 41032

	» Service: Other

	» Protocol: IPv4

NOTE: When first connected to the SirettaLINK Management Portal, the newly connected 
SL500 modem will check to see if there is a newer version of software available. If there is, it 
will download and apply it to the modem. During the download process the SL500 modem will 
continue to work normally as the software download will happen in the background. However, 
to apply the update the unit will reboot. This means that the data link provided by the modem 
will go down while the modem is rebooting and re-acquiring a network connection. The 
software download will occur shortly after the SL500 modem is connected to the portal, and 
this will normally take 2 to 3 minutes to complete (dependant on network speed).

It is now possible to see data pushed from the Siretta test server to the SL500 modem. 

Figure 12. Data being pushed 

http://www.siretta-link.com
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The SirettaLINK Management Portal provides a large range of information about 
how the SL500 modem is set up, used and performs on the cellular network. Full 
instruction of the use of the SirettaLINK Management Portal is available in the 
‘SirettaLINK Management Portal User Manual’. This section provides a quick overview 
of the device settings of your newly connected SL500 modem.

SirettaLINK Management Portal

Device Connection Overview
Click on the ‘Device’ tab on the SirettaLINK Management Portal to get an overview of 
the SL500 modem attached to the portal account. Initially it will be just one unit, but 
as devices are added the list will increase.

Figure 13. List of devices

Overview of modem connected to
SirettaLINK Management Portal
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You will see a summary about the connection status of the SL500 modem that has 
just been configured. Hovering the mouse over any information about the unit will 
display a popup giving more detail and what action will occur by clicking on it. For 
instance, if you hover over the signal strength bar you will get more information about 
the network operator being used, the network technology and the signal strength 
measurement itself, as shown in the figure below.

Figure 14. Signal strength overview

Hovering over different sections will expand 
information displayed

The explanation of the data in the columns is as follows:

Device: Device name. This defaults to a system generated name of “New Unit – <last 
5 digits of IMEI number> (date added)”. This can be changed to a different name. 
When a firmware update is in progress the lettering will turn red.

Signal: Signal strength indicator.

Error Log: Access the error logs from the SL500 modem.

Cell Technology: Indicates technology the SL500 modem is connected to.

SMS History: Access SMS log history from the SL500 modem.

Mode: Mode of the connection. The default setting is Client Maintain (the ‘M’ symbol 
shown), which means the SL500 modem is acting as the client (therefore does not 
need a fixed IP address) and is maintaining an “always on” link with the server. Other 
possible modes of operation are Client Mode (‘C’) and Server Mode (‘S’). In Server 
Mode, the SIM used in the SL500 modem must have a fixed IP address. In Client 
Mode, the connection is opened only when the link is required.
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Profile: Name of the profile used in the SL500 modem. A newly added SL500 
modem will display as ‘New Connection Profile’. Profiles describe all aspects of a 
device’s configuration and allow for rapid cloning of settings for new devices.

Device History: Access to historical device status, signal strength and traffic logs 
and graphs. Up to 7 days history is available.

Software: This will display as ‘Up to date’ if the SL500 modem is running the latest 
software. If the software is not current, the latest version available is displayed against 
a pink background.

Last Seen: Duration since SL500 modem was last in contact with the SirettaLINK 
Management Portal. The system default update rate is 90 seconds which means that 
the last seen time should not exceed 90 seconds, however, when devices are having 
connection difficulties or have been powered off this time will be higher.

Summary: Connection status of the customers application server. This could be 
‘Connected’ or ‘Disconnected’. It could also display ‘Waiting’ which occurs when 
SL500 is trying to connect to the customers application server or is idle in server 
mode and is waiting for an incoming socket connection.

Device Settings: Edit configuration options and allows them to be changed.

Delete Device: Deletes the device from the SirettaLINK Management Portal.

Uptime: Duration that the SL500 modem has been connected to the SirettaLINK 
Management Portal. This could also show as ‘Online Pending’ where the 
configuration has just been changed using the portal and the portal is expecting the 
SL500 modem to connect to the server and download the new configuration settings, 
or ‘Offline pending’ where the SL500 modem appears to be disconnected from the 
network (or powered down).

Device Location: Last known location of the SL500 modem. This value is not 
automatically generated. Click this field to go through to the position tab where 
position will be calculated based on the cell that the SL500 modem is connected to. 
Initially there will be a red bar through the symbol indicating that a position has not 
been determined.

Device Summary: Access to full device summary detailing how the device is 
connected and configured, data usage and connection information.
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